Terug naar overzicht
Opgelost

Schoolware is offline

Jul 9, 2026 at 6:58am UTC
Getroffen services
Schoolware

Opgelost
Jul 9, 2026 at 7:04am UTC

Schoolware is hersteld.

Aangemaakt
Jul 9, 2026 at 6:58am UTC

Schoolware is offline gegaan.